diff design.txt @ 367:2fadf8695f8a

Use 'revision index' instead of the vague 'local revision number' concept in the API
author Artem Tikhomirov <tikhomirov.artem@gmail.com>
date Fri, 16 Dec 2011 15:37:27 +0100
parents 9ce3b26798c4
children 0ae53c32ecef
line wrap: on
line diff
--- a/design.txt	Fri Dec 16 04:43:18 2011 +0100
+++ b/design.txt	Fri Dec 16 15:37:27 2011 +0100
@@ -126,3 +126,16 @@
 
 Need better MethodRule than ErrorCollector for tests run as java app (to print not only MultipleFailureException, but distinct errors)
 Also consider using ExternalResource and TemporaryFolder rules. 
+
+
+=================
+Naming:
+nodeid: revision
+int:	revisionIndex (alternatives: revisionNumber, localRevisionNumber)
+BUT, if class name bears Revision, may use 'index' and 'nodeid'
+NOT nodeid because although fileNodeid and changesetNodeid are ok (less to my likening than fileRevision, however), it's not clear how
+to name integer counterpart, just 'index' is unclear, need to denote nodeid and index are related. 'nodeidIndex' would be odd.
+Unfortunately, Revision would be a nice name for a class <int, Nodeid>. As long as I don't want to keep methods to access int/nodeid separately
+and not to stick to Revision struct only (to avoid massive instances of Revision<int,Nodeid> when only one is sufficient), I'll need to name
+these separate methods anyway. Present opinion is that I don't need the object right now (will have to live with RevisionObject or RevisionDescriptor
+once change my mind) 
\ No newline at end of file